Jesteś tutaj: SerwisForumTechnikaOświetlenie


Moja pierwsza belka LED



Dobór oświetlenia do akwarium roślinnego.
Wybór lampy, pokrywy, świetlówek. Diody LED.

21 wrz 2017, 17:35 Moja pierwsza belka LED  (#1)  

Moja pierwsza belka LED.
Witam postanowiłem zrobić oświetlenie LED. Problem w tym ze nie mam pojęcia o elektronice,
kopiłem Driver P4115H Oraz LM317 + Rezystor 3,9K Oh.
Wybór padł na układ z P4115H sterowany Arduino.
Zasilacz 24V
Dioda Epistar 1W 3,2-3. 4 V 90-120LM

Pytanie 1:
Moge uruchomic uklad na P4115H jezeli nie mam jeszcze Arduino- wyjście PWM nie podłączone?
Pytanie 2 :
Jak podłączyć Arduino jeżeli zasilacz ma 24V a do Arduino można max 12V podłączyć?

Moja pierwsza próba odpalenia 6 diod chyba nie wyszła, nie wiem co zle robię.
Miernik nawet pożyczyłem ale co z ego jak nie wiem co i jak Mierzyc :roll:
Załączniki
2017-08-22 09.55.34.jpeg
2017-08-22 09.55.34.jpeg (12 KiB) Przeglądane 3407 razy
2017-09-21 13.38.06.jpg
2017-09-21 13.38.00.jpg
2017-09-21 13.38.10.jpg
2017-09-21 13.48.46.jpg
2017-09-21 13.49.01.jpg




michaljanus
Początkujący
 
Posty: 22

 

michaljanus napisał(a): + Rezystor 3,9K Oh.


Mam nadzieję że to czeski błąd, ma być około 3,9 Ohm, a nie 3,9K Ohm

michaljanus napisał(a):
Moge uruchomic uklad na P4115H jezeli nie mam jeszcze Arduino- wyjście PWM nie podłączone?


Możesz, tylko drivery na jaki prąd kupiłeś?

michaljanus napisał(a):
Jak podłączyć Arduino jeżeli zasilacz ma 24V a do Arduino można max 12V podłączyć?


Np. przez stabilizator LM7812 albo lepiej LM7809 Tylko lepiej w obudowie TO220

michaljanus napisał(a):
Moja pierwsza próba odpalenia 6 diod chyba nie wyszła, nie wiem co zle robię.


Nic nie świeci, ani się nie żarzy?
A sprawdzałeś czy zasilacz podaje napięcie?
A tak na przyszłość. To jak łączysz kabelki to czerwone do plusa, a czarne czy brązowe do minusa A Ty masz wszystko na odwrót :wink:
Prościej jest potem się połapać.
Pozdrawiam
Artur


Avatar użytkownika

Utul
Znający temat
 
Posty: 1053
Miasto: Marklowice

Ok. Kabelki poprawię! Nic się nie świeci nic się nie Żarzy.
Jedyne co udało mi się zmierzyć to napięcie na wyjściu i wynosi ono 24V.
Driver kupiłem na 320mA




michaljanus
Początkujący
 
Posty: 22

Co nieco dziwne. Kabelki wyglądają dobrze podłączone.
Masz więcej tych modułów LED, i tych driverów?
Spróbuj pozamieniać może coś jest walnięte.
Pozdrawiam
Artur


Avatar użytkownika

Utul
Znający temat
 
Posty: 1053
Miasto: Marklowice

No właśnie też mi się to wszystko dziwne wydaje. Wydawało mi się że jestem w miarę przygotowany aby zacząć przygodę z diodami LED. A tu nic, totalna ciemność.
Następna próba będzie dopiero w niedzielę, napiszę czy coś się ruszyło i jak to wygląda.




michaljanus
Początkujący
 
Posty: 22

W pierwszym przypadku - LM317 + rezystor.
Masz źle dobrany rezystor. Ma być 3.9 Ohm a ty masz 3.9 kOhm (3900 Ohm)

W drugim przypadku podejrzewam błąd w lutowaniu diod.
Jeśli masz miernik to ustaw pokrętłem na test diod (symbol diody) i jak będziesz czerwoną końcówką do plusa a czarną do minusa do dioda powinna się lekko świecić.
Gdy masz źle polutowane lub odwrotnie do nie ma przejścia przez całą sekcje i dlatego nie świeci.

Na zdjęciu masz zaznaczone gdzie podejrzewam przyczynę niedziałania.
Clipboard01.jpg


Do zasilania Arduino:
- LM7812 lub LM7809
- przetwornica LM2596 ustawiona na około 9V

Do LM78xx na wejściu użyć kondensator w okolicach 100-470uF oraz 100nF a na wyjściu kondensator 100uF oraz 100nF.
Do Arduino do wystających pinów GND (minus) oraz +5V (plus) przylutować kondensator 100uF oraz 100nF.
Po wgraniu oprogramowania do Arduino do pinów GND oraz RSt przylutować kondensator 1uF.


Avatar użytkownika

pietach
Znający temat
 
Posty: 1797
Miasto: Wschowa

DSC_0003.JPG




michaljanus
Początkujący
 
Posty: 22

A może byś napisał gdzie był błąd - jako info dla innych potencjalnych majsterkowiczów.


Avatar użytkownika

pietach
Znający temat
 
Posty: 1797
Miasto: Wschowa

 



Jak widać świeci, dziękuję za pomoc, jak widać każdy potrafi z odrobiną pomocy. Teraz czas wszystkie elementy zlutować i czas na Etap II.
Zanim nastąpi dalsza część mojej przygody muszę ostatecznie ustalić co bym tak naprawdę chciał.
AKWARIUM do którego ma być oświetlenie jeszcze nie jest w moim posiadaniu. Ma być to 130x50x50.
Profile 120x16cm już kupiłem i zastanawiam się nad rozmieszczeniem diod.
Kupiłem Led 6500k ok 200szt. Oraz 20 full spectrum.




michaljanus
Początkujący
 
Posty: 22

DSC_0021.JPG




michaljanus
Początkujący
 
Posty: 22

Jak widać świeci,

Dlaczego nie świeciło?


Avatar użytkownika

pietach
Znający temat
 
Posty: 1797
Miasto: Wschowa

Błąd był jak najbardziej w złym i niedokładnym lutowaniu. Wszystko poprawiłem i działa.




michaljanus
Początkujący
 
Posty: 22

Dzisiaj chciałem pochwalić sie moimi postępami w budowie beliki, Ale niestety nie ma sie czym chwalić bo 10 moich Driverów P4115H chyba sie wypaliło :(
1. Jak mogę to sprawdzić co i jak mierzyć? na wyjsciu nie ma napiecia.
2. Niestety chyba to moja wina bo kleiłem to na silikonie- nie wiem czy byl jeszcze mokry (czekalem 2 dni) i jakieś przebicie, nie mam pojęcia.
Załączniki
2017-10-04 17.04.55.jpg




michaljanus
Początkujący
 
Posty: 22

Tak to miało wyglądać
Załączniki
2017-10-03 17.02.11.jpg
2017-10-04 16.45.53.jpg




michaljanus
Początkujący
 
Posty: 22

Czy ten Silikon to jest dobry pomysł na klejenie driverów, jak wy to robicie, na co zwracać uwagę ile czekać, czego używać a czego nie?




michaljanus
Początkujący
 
Posty: 22

Na moje to powinieneś użyć kleju termoprzewodzącego.


Avatar użytkownika

Skajor
Poznaje temat
 
Posty: 73
Miasto: Poznań - Grunwald

Ta część mi zaczęła się w moich P4115 palić co to jest? Jaki może być tego jeszcze powód? Jeżeli by założyć że silikon nie był winien.
Załączniki
sketch-1507143980348.png




michaljanus
Początkujący
 
Posty: 22

To co zaznaczyłeś na zdjęciu to właśnie pt4115, serce układu.



mateuszurad
Stały bywalec
 
Posty: 465
Miasto: Krzeszyce

mateuszurad napisał(a):To co zaznaczyłeś na zdjęciu to właśnie pt4115, serce układu.

Dlaczego mi się to zaczęło palić? . Katastrofa moja wymarzona Lampa to już jest jakiś koszmar.




michaljanus
Początkujący
 
Posty: 22

michaljanus napisał(a):Ta część mi zaczęła się w moich P4115 palić co to jest? Jaki może być tego jeszcze powód? Jeżeli by założyć że silikon nie był winien.


To jest właśnie scalak PT4115, taki sterownik całego driwera
Silikon raczej nie jest winny, tylko coś Ci tam za wysokie prądy idą.
Modziłeś tam coś z tymi trzema opornikami?
Pozdrawiam
Artur


Avatar użytkownika

Utul
Znający temat
 
Posty: 1053
Miasto: Marklowice

Nic tam nie zmieniałem, lampa cała się zaswiecila, oprócz jednego układu (pewnie brak styku) wyłączyłem, popatrzyłem czy wszystko styka, jeszcze raz włączyłem i już nic tyko lekki smród. Mierzyłem na zasilaczu było 24V. Jutro jeszcze posprawdzam zrobię zdjęcia i wrzucę na forum. Mam nadzieję że będzie ok. PT4115 Jeszcze mam bo w planach są dwie belki.




michaljanus
Początkujący
 
Posty: 22

Teraz zauważyłem, że na zdjęciu "jak to powinno wyglądać" że strona drivera gdzie jest scalak była posmarowana silikonem i przyklejona.
Silikon jest raczej izolatorem termicznym. Tym samym scalak nie był chłodzony, no i się zjarał.
Pozdrawiam
Artur


Avatar użytkownika

Utul
Znający temat
 
Posty: 1053
Miasto: Marklowice

 



No jak widać to Elektronik ze mnie żaden .
1. Kleic odwrotnie?
2. Wymienić serce PT4115, powinno działać?




michaljanus
Początkujący
 
Posty: 22

Wymienić srerce to raczej ciężka sprawa.



mateuszurad
Stały bywalec
 
Posty: 465
Miasto: Krzeszyce

Kleić odwrotnie.
Najpierw jakaś tektura a potem płytkę kondensatorem i dławikiem w dół - na silikon.
Tylko piny trzeba przelutować na drugą stronę

20170120_220119-2.JPG


Nie musisz kupować nowych driverów - wystarczy wymienić tylko sam układ scalony - koszt około 1 zł ale potrzebne umiejętności w trzymaniu lutownicy i cierpliwość bo maleńkie dziadostwo.



Właśnie aby uniknąć takich przygód robię sobie sam drivery na płytce jednostronnej - wygoda w przyklejaniu.
20170913_225350.jpg

016.jpg


Avatar użytkownika

pietach
Znający temat
 
Posty: 1797
Miasto: Wschowa









Serwis roslinyakwariowe.pl


 
  Działamy od 2001 roku i wspólnie z ponad 44 tysiącami akwarystów z całej Polski zdobywamy wiedzę i dzielimy się naszym doświadczeniem. zamów e-Magazyn na e-mail

Salon firmowy w Krakowie

Zapraszamy do odwiedzin naszego sklepu i galerii
akwariów w Krakowie przy ul. Wielickiej 42a.

Poniedziałek-piątek: 11:00 - 19:00
Sobota: 10:00 - 14:00

mapa dojazdu


Użytkownicy przeglądający ten dział: torman i 6 gości